Sign In Register

How can we help you today?

Start a new topic

Unity WebGL websocket removed before opened

I tried to do a WebGL build using the Unity SDK and I am not able to authorized a device connection with GameSparks. I have the GameSparksUnity.cs script (followed the tutorial) in the scene along with GameSparks Manager script that is a singleton which works fine in the editor. I am able to send requests and retrieve responses. 

The image below shows the error I get when sending a device authorization request (done by GameSparksUnity.cs). In the chrome dev tools console, I see that 2 websockets are there, but one is removed. I tested this in firefox browser and it produces the same error. In the networking tab the current selected item is the websocket and the status is '101 switching protocols'. I done some searching and I am not able to figure out how to allow websocket connection. I read there could be a problem with a antivirus, but I only have windows defender.


Any ideas?


1 Comment

Fixed this problem. I had to go into the WebGL settings in player settings and check 'allow unsafe code'.

Login to post a comment