Sign In Register

How can we help you today?

Start a new topic

Rename "LeaderboardEntriesRequest" or "GetLeaderboardEntriesRequest"

There is an API request called "LeaderboardEntriesRequest" and another called "GetLeaderboardEntriesRequest". These names are too similar, and confusing. It is impossible to guess the difference between the two types of requests from the names


Hi Kevin,


The differences between the LeaderboardEntriesRequest and GetLeaderboardEntriesRequest are detailed in our documentation. Essentially the GetLeaderboardEntriesRequest will only return a single entry for the given leaderboards whereas the LeaderboardsEntriesRequest should be used if your leaderboards contain more than one entry for the player (or players). We can look into making this clearer in the documentation.


Regards,

Liam 

Hi Liam,


I am aware of the documentation and understand the differences. Surely your team is aware that it is bad practice to give functions confusing and ambiguous names? When two functions have similar but separate purposes, the names of those functions should make the difference in functionality clear. Prepending "Get" to the function name does not provide any clarity.


You should rename "GetLeaderboardEntriesRequest" to "GetHighestLeaderboardEntry" or something similar that properly conveys the difference between the two functions.


Thanks,

Kevin

Login to post a comment