Sign In Register

How can we help you today?

Start a new topic

Get my Custom SDK freezes

Just installed latest Unity 2018.2 and last Gamesparks plugin. Added custom Scrip Message "DebugLogMessage" and tried to download this custom sdk to Unity, but it freezes fo ~5mins (CPU & fans worked hard) and after unfreezing nothing changed - my ScriptMessage_DebugLogMessage wasn't added.

Any suggestions? Never had this issue before

Hi, I got the same problem with an existing project where I just installed the GSparks plugin (2018.2.1f1). Though, with another project that only have very little test/dev code + the GSparks plugin, everything works fine (2018.2.1f1 & plugin V5.6.5.214 too) I can copy the custom SDK source from 1 project to the other as a workaround.

Could it be because the 2 projects are on the same machine uses the same API key + secret ? (some registry/cache related conflict ?). Or have you found the cause ?

For info: it seems to be linked to Scripting Runtime Version in the Player Settings: .NET 3.5 works, .NET 4.x freezes. Ticket submitted.

Devs, that definitely should be fixed asap..

1 person likes this

Hi guys,

Support for the 4.6 .net framework is planned for the SDK in the next couple of months. For now please use 3.5 to ensure compatiblity.



@Liam we just faced this problem yesterday, we spent hours trying to figure what was the problem until we found this post now .net framework 3.5 its deprecated  when do you guys plan to update the SDK?

Just updated the SDK and see that there is now a message about the 3.5 compatibility. We've been using the previous SDK for months without any issues on .net 4x in Unity. It's also been quite a while since this thread was started so just checking if this is really not compatible?

Login to post a comment