Sign In Register

How can we help you today?

Start a new topic

GameSparks Messages not being received

I am working with Unity on a multiplayer game where I need to find matches and start a challenge. I successfully registered and authenticated and received responses from gamesparks. After being authenticated when I send a MatchMakingRequest to gamesparks, it accepts that response(then even sends me a successful MatchMakingResponse), however I don't receive a MatchFoundMessage(I correctly did set up the listener as well) neither a MatchNotFoundMessage. And the weird thing going on here(which I got to know after checking the matchInstance MongoDB database) is that a match instance does gets created.

 

I am basically using two clients to test my code ->

 

1. My unity editor.(even have used an android device but same error there as well)

 

2. Test harness tool of gamesparks


It seems that the match is being made successfully for the two clients, however my unity code is not able to receive the MatchFoundMessage/MatchNotFoundMessage(even other messages that I may not have tested).

 

I have seen similar questions in the gamesparks forums and I am still not able to find a convincing answer regarding this. Is this a bug in gamesparks or are the documentation not updated. I really can't figure out why. I have been stuck on this past three days. Please help!

 

Login to post a comment