Sign In Register

How can we help you today?

Start a new topic

Unity SDK on Android using IL2CPP + .NET 4.6

Not sure if this is intentional or not, but the GameSparks SDK doesn't seem to work with Android when you build using IL2CPP and .NET 4.6. It works correctly with Mono + .NET 4.6 however and both Mono and IL2CPP with .NET 3.5....

9 people have this problem

Hi Sacha,

This is in our backlog and the SDK team does plan on adding this support in the future. I don't have exact date of when this will be available I'm afraid. I'll update the post when I have more info.



1 person likes this

Hi Liam,

Instead of creating a new ticket, I thought I would add to this thread.

We are in the process of adding GameSparks to a game we are working on and we're getting the attached stack trace when trying to Initialise GameSparks with the following setup:

  • Unity 2018.1.6f1
  • Scripting Runtime Version: .NET 4.x Equivalent
  • Scripting Backend: IL2CPP
  • API Compatibility Level: .NET Standard 2.0
  • Build Target: Android
  • Target Architectures: ARMv7

We can't downgrade the Scripting Runtime Version to 3.5 at this point because we have used newer features only available in 4.x a lot so a downgrade would involve a lot of code rewriting.

We would prefer not to change our Scripting Backend to Mono as the improved performance and added security of IL2CPP is something that we would very much like to keep. Switching to Mono would also involve a complete new round of testing to make sure that the switch has not introduced any regressions.

If there is anything we can do to help speed up the addition of support of this, then we would be happy to help in any way possible. If it would be possible for us to get access to and help test early versions of the SDK with support for this feature, then that would be something that we'd be interested in as well.



(2.84 KB)

7 people like this

Scott - did you get a resolution to this? We are now in a position where Unity no longer supports Scripting Runtime 3.5 and the GameSparks SDK is causing problems.

Hi, I have same problem here also. I need to use GameSparks with .Net 4.5.

I saw on this thread

That it might be a workaround, but I am having some problems with the socket connection.

Is there any word on when the GameSparks SDK will be made .net 4.x compatible? .net 3.5 has been deprecated in Unity for quite some time now, and going back to an older version of .net or Unity is not an option.

Login to post a comment