Sign In Register

How can we help you today?

Start a new topic
Answered

Testing in a Live Environment

Hi,

I'm ready to test the "live" version of my game but in order to do so I have to publish a snapshot of it according to your guide (https://docs.gamesparks.com/getting-started/going-live-checklist/)? I've already noticed that if I turn off "Preview Build" in my game (Unity) it doesn't connect (the game technically isn't publicly available yet so the only person connecting would be me).

Also, as I'm on the Indie/Student Program: regarding the 1st 100,000 MAUs per month being free, is it safe to assume that this number resets on the 1st day of the month?


Best Answer

Hi Guys,


Yes you do need to have a Live snapshot in place to connect to live. Jan you have a Dev and Live stage configuration for you game. The Dev instance has the live snapshot. Which one are you trying to connect to here ? Trying to connect to live on the live instance won't work as you don't have a snapshot published there.


Regards,

Liam


Experiencing the same issue!

I published my snapshot in my test environment and disabled "Preview build", but after this Unity doesn't connect to the Gamesparks server anymore. It's like Gamesparks is not included in the first place.
I'm running the newest SDK.

I haven't published my snapshot yet but if this is something that's happening to a lot of other people then it might be a problem (Also maybe we have wait a few minutes for the server to recognise that the snapshot is live or something?).

 

As far as I know, you need to publish your snapshot, otherwise Gamesparks can't find your game on its live servers.

But lets maybe wait until we get some official response on this.

Seems like customer support is currently quite slow?

Answer

Hi Guys,


Yes you do need to have a Live snapshot in place to connect to live. Jan you have a Dev and Live stage configuration for you game. The Dev instance has the live snapshot. Which one are you trying to connect to here ? Trying to connect to live on the live instance won't work as you don't have a snapshot published there.


Regards,

Liam

I'm trying to connect to the "Dev" configuration with the snapshot, as this is still testing.

The "Live" configuration is just pre-made for the actual live usage later on.

Hi Jan,


When you have preview unchecked in Unity can you run the test scene and let us know what you see please ? Please log a ticket to share your logs (if required) and we'll look into this for you further.


Regards,

Liam

After testing again, it works now magically! Maybe we really need to wait like 24 hours after making a snapshot before testing again?


The only new problem I have now is that in the new snapshot, my collections are empty again. I know I can transfer collections to a new snapshot when doing a copy, but apparently not when I create a new one? I probably miss something here.

Hi Jan,


No, it should be instant. The live and preview databases are separate though. Only meta collections can be pushed from preview to live. This is covered in the Going Live Checklist here. If you have any further questions then just let me know.


Regards,

Liam

Login to post a comment