Sign In Register

How can we help you today?

Start a new topic

UE4 iOS Game crashes when it connects to Game Sparks.

 IOS Shipping build crashes every time it connects to Game Sparks. 


3 people have this problem

Hi all,


A fix is incoming for this issue. It should be ready soon. I'll update you all once it's available.


Regards,

Liam

This thread is legitimately worrisome.


If I'm reading this correctly, GameSparks currently does NOT support UE4 on iOS. Is that right?


-Luke

Hi @Dark Horse

We solved the problem for our game so we switch to Chilli Connect. They provide great support. 
https://www.chilliconnect.com/

Regards
Simon

Hi

Please help me.

I have the issue i am developing on 4.19 and tried to do a build with 4.19 same result crash. 

ASAP!

Hi Simon,


We're actively pushing for a resolution to this issue as soon as possible. I'll post any related updates here for you guys.


Regards,

Liam

Hello, we are also experiencing crashes on IOS when building with shipping in Unreal Engine 4.18.1. Has any fix for this been found. We are due to release quite soon on IOS and this crash puts us in quite the bind right now.

 Hi guys,


Unfortunately this hasnt been fixed yet. Epic has told us that this is a complex issue and one that they think apple should fix. We've got a couple of work around we will try but no ETA on when this will be fixed. Sorry for any inconvenience.


Cheers,

Omar

We tried to resign with iResign but it was no longer applicable, perhaps apple prevents resigning. Unfortunately this bug is catastrophic for our app and has currently put us out of business, we are desperately looking to solve this problem. Do you have any other ideas how to fix or work around?

Yes i packaged my game in develpment, then resigned that ipa with distributon using iResign or somethin like that i dont remember.

 

Hey Omar,

We have the same problem we are developing on 4.16.3 and tried to do a build with 4.16.3 and 4.17 same result crash. When we disconnect all Gamesparks BP nodes it works. 

Is there a fix for your Plugin or workaround? 

Hey,

 

We are aware of this problem, and currently it blocked launch of our game on iOS

Please let us know about the status of it.

 

Thank you.


1 person likes this

Can you try it with 4.17?

We know this is something that Unreal needs to fix. Perhaps they fixed it in the newest engine version?


Cheers,

Omar

I'm on  4.16.3.

 

Hi Zaur,


We are aware of this issue and have raised a ticket with Unreal to pursue a solution. Just out of curiosity, what engine version are you on?


Unreal Ticket: https://issues.unrealengine.com/issue/UE-45650


Cheers,

Omar

Login to post a comment