Sign In Register

How can we help you today?

Start a new topic

teamType MAX_MEMBERSHIP_REACHED

Hi,


My players are suddenly getting the teamType error "MAX_MEMBERSHIP_REACHED".  I've tried setting the team max membership to 999 to see if that fixes it but am not sure why it suddenly happened or how to fix it.  


1 person has this question

Isn't that because of new GS javascriptUpdate? Because I have this issue too and hadn't it before

 

Hi Guys, 


Can you share the team configurations used here ? What was Max Membership Per User set to before you changed it to 999 ?


Regards,

Liam

I had both set to 1 beforehand and it worked fine.

Hi Steven,


This error is returned when you try to join a team of a particular type, but you are not allowed to join any more teams of that type.

The important piece of config in the Portal in this case is "Max Membership Per User" (not "Max Members").

It's hard to be certain without knowing the details of your game configuration, but what appears to be happening is that your player is already a member of a team and is trying to join another one of the same type.

For example:

In the Portal, you set up a Team configuration with a short code of "Clan". You set the "Max Membership Per User" to 1.

Lots of Teams of this type (Clans) are then created in the game, such as the teams "Wondrous Wizards" and "Wicked Warriors".
A new player (Player1) joins "Wondrous Wizards". This works fine since they are not a member of any Clans yet.

If Player1 then tries to join "Wicked Warriors" they would get this error response, since the "Clan" Team is configured to only allow each player to be in 1 clan at a time.

If you change the "Max Membership Per User" to 2, then Player 1 would be allowed to join "Wicked Warriors" and be in 2 clans at once. If Player1 tried to join the clan "Heroic Healers" they would receive the "MAX_MEMBERSHIP_REACHED" error again, since they are (now) only allowed to be in 2 clans at once.


I hope this makes sense. If you have any further problems, please raise a ticket (including the API key of your game) so we can investigate further.


At the moment, I have no reason to believe this is an issue with the JavaScript upgrade in the Preview environment since this functionality is not linked to JavaScript at all (you don't need to write any cloud code to use Team functionality).


Kind regards,


Jonathan.

Login to post a comment