Sign In Register

How can we help you today?

Start a new topic

Unity hang up on play in editor.

I'm using gamesparks with "Ultimate Mobile" asset.

It's freezing when using two assets.

And there is no error and warning message.

If I play with just gamesparks or just "Ultimate Mobile" asset, there is no issue.

Unity : 5.5.1f1
GameSparks : 5.5.3.204
Ultimate Mobile : 9.4/17

2 people have this problem

I revert my GameSparks sdk to 5.4.0.104 and it worked normally.
What changes inside?

1 person likes this
I profiling project and found GameSparksSettingsEditor::FixSDK() function.

This function run "find files/directories and deletes" every time in editor mode.

If I use "Ultimate Mobile" asset with GameSparks, play in editor mode start time is horrible.(Almost 1 minute.)

Same occuring to me. Unity is beeing frozen only with gamepasrks added since version 5.5.1 on unity 5.5.1f1 when recompiling.
I did reverted to gamesparks 5.4.0.104 as Lim advised and the hangouts are rarer now, but sometimes it still happens on recompiling the code

Hi Leandro,

This is temporary solution.
Remove or comment out [InitializeOnLoadMethod] above GameSparksSettingsEditor::FixSDK() function.
Then issue is solved.

 


1 person likes this

Hi, I have the same issue, when editor freeze after start play. Unity version 5.6.1, GS SDK ver 5.5.5.92

If you press to Play and quickly unpress after that you can work during some time, when you put some changes in code,after play, freeze happens again.

Please help to fix that. 

This is still happening.


Will this ever be resolved?


thank you

This is also happening to me on Unity2017.1.1p2. I've tried the temporary solution without luck. I can't believe that this issue is not resolved yet..

I'm now considering other solutions just because this issue makes this FWK unusable..

BTW, I'm using Gamesparks 5.5.114 + Facebook SDK

Update: it looks like a new version was pushed recently: 5.5.6.130. Still not working..

Hi Guys,


Please raise a ticket with support to have any of these issues diagnosed further.


Regards,

Liam

It's 100% GS: http://recordit.co/Ch88WyrF4a


Raising a ticket now

Hi Guys,


Dylan has kindly tested a fix which has addressed this issue for him. It will be included in an upcoming SDK release. it should be available in the next week or so.


Regards,

Liam

Login to post a comment