Sign In Register

How can we help you today?

Start a new topic

Portal IDE hangs

Hi,

since I updated my google chrome to version 53.0.2785.116 m the browser IDE hangs very often after I try to access an object property. Like writing Spark. (now normaly the auto completion triggers but the window freezes). I always have to close the window and reload the portal. All unsaved changes are lost.


2 people have this problem

Hi David,


I'm on Version 53.0.2785.116m myself and am not seeing the same behavior. Can you let me know what OS you are running ? Does it work in another browser ? Are you running any plugins at all in Chrome ?


Thanks,

Liam





I am running on windows and I don't use any plugins except AdBlock. It worked great before the browser update and is still working in Firefox. My colleagues have the same problem with the new chrome version.

When I open the developer console, I see a lot of "Recursive require detected" logs when I move the cursor around. When I try to auto complete something, those logs just go crazy. Maybe you could prevent some loops there on your side? (Don't know anything about your implementation though...).

Hi David,


Would you be able to post a screen shot of what exactly happens when you try to autocomplete. This will aid us in getting to the bottom of this issue.


Thanks,

 - Steve

Hi Steve,


I opened a support ticket for the screenshot.


Thanks,

David

Hi David,


Just posting here to clarify for any other users with a similar problem. Clearing the Chrome Cache solved the issue.


Thanks,

Liam

I am sorry to reopen this. Since the hang occurs randomly I thought that clearing the cache solved the problem. But it didn't. At the moment this makes it almost impossible to work with chrome.

Hi David,


No problem, do you have any plugins enabled in Chrome when this is happening ?


Thanks,

Liam

Hi Liam,


I will try if deactivating all plugins will work.

Hi,


Same problem here. It also started when my chrome updated to same version as David.


Can't add more info, it hangs randomnly. I only have the "Avira Browser Safely" plugin installed.


Best!

Hi Mark,


Does disabling this plugin resolve the issue ?


Thanks,

Liam

Same issue with the ide hanging. Only started happening a couple days ago. *Very* disruptive.


Chrome: Version 53.0.2785.143 (64-bit)

OS: macOS Sierra


My only plugin is uBlock and I won't try without it because I've use it for years with no interference without it. It's clearly something with the latest chrome and/or some Gamesparks change.


Please fix urgently.

Hi Ryan,


Just to confirm, is this hanging when trying to auto complete in the editor also ? 


Thanks,

Liam

Disabling all plugins does not help. When I found a way to reproduce it reliable, I can send you an API key and instructions on what to do.

But until now, it happens quite randomly.

This makes it really impossible to work. Is there any progress on this?


1 person likes this
Login to post a comment