Sign In Register

How can we help you today?

Start a new topic
Answered

Often no connection to server while starting game in editor

I've had this issue for quite a while now and its quite annoying., 

About 33% of the time when starting the game, the connection to GameSparks just doesn't happen, it gets stuck at the point where the editor log is showing...


GS: Connecting to:wss://preview.gamesparks.net/ws/2896355Nv0dk?deviceOS=ANDROID&deviceID=660ffe43f343aee5df002f5f216a93ac14f56bbf&SDK=

UnityEngine.Debug:Log(Object)

GameSparks.Platforms.<DebugMsg>c__AnonStorey60:<>m__30() (at Assets/GameSparks/Platforms/PlatformBase.cs:144)

GameSparks.Platforms.PlatformBase:Update() (at Assets/GameSparks/Platforms/PlatformBase.cs:67)


And doesn't get any further than that. I then have to stop it running and try again. 


Why does this happen? 


Best Answer

Hi,


Thank you, upgrading to the latest SDK version 5.3.5.201 does seem to fix this issue after numerous tests. Awesome!


Hi Greg


What version of the GameSparks Unity SDK are you using?


Regards

Katie

This happens to me as well. A weird workaround is to build and run to PC and then try the editor. Hope that helps a little.

Hi Katie,


I'm using the 5.3.4.167 SDK. But I've had this problem pretty much with every SDK version from Gamesparks. 

It does only seem to happen in the editor, thank goodness, but its still annoying as it wastes about 15 seconds of time every time it happens. 

Hi Greg,


I believe this issue was addressed in an SDK released after 5.3.4.167, can you try updating your SDK here and let us know if you still see this issue ?


Thanks,

Liam

Answer

Hi,


Thank you, upgrading to the latest SDK version 5.3.5.201 does seem to fix this issue after numerous tests. Awesome!

Hey Greg,

Happy to hear it. 

Regards, Patrick. 

I'm facing the same error after updating to SDK Version : 5.5.5.92.

It is simply never connecting.

Please advise

Update:

Downgrading to Unity Asset Store version now atleast it connects fine.

Login to post a comment