Sign In Register

How can we help you today?

Start a new topic

Unity 5.3.4f1 can't install GameSpark SDK

After installing package error appears in console: 

Assets/GameSparks/Editor/GameSparksRestWindow.cs(21,40): error CS0117: `PlayerSettings' does not contain a definition for `WSA'

Google doesn't give any advices.

Help needed


Update: install into empty project goes OK. Looks like the problem is somewhere in project.


Hello Peter,

I suppose you are building it for Windows Store platform. Have you already checked your Player settings? Moreover could I see which platforms have been selected in GameSparks files placed in Assets/Plugins, please?


Thanks,

Giuseppe

Hey Peter,

it seems an error that occurs into building script. Have you tried to remove completely the plugin from your project and then install it again?


Giuseppe

Hey! 

Yeah, tried to do so on several projects, deleting the folders with plugin and installing them again, still the same. Will try to solve issue today with some friends of mine.

I do "select all" when importing package

player settings and some other attached 


png
(176 KB)
png
(85.9 KB)
png
(62 KB)

Hi Peter,

I see you're building for iOS and I suspect that somewhere in the code the active build target is switched to Window Store platform. Could you find whether you use the method EditorUserBuildSettings.SwitchActiveBuildTarget? Have you already tried to remove the other plugins first (if you have them)? Do you get this error during build&run operation?


Thanks,

Giuseppe

For sure i haven't used EditorUserBuildSettings.SwitchActiveBuildTarget in code, and i have none other plugins installed

This error comes just after adding GameSparks package

Ok, did you try it with old versions of Unity?

Does it occur only on iOS building?


Giuseppe

Login to post a comment