Sign In Register

How can we help you today?

Start a new topic

GameSparks Hang up on Initialization in Unity3D

I noticed strange behaviour in my case. 

Everything is updated on my side in regards of code and setup.

When GS should initialize it prints out in console that it is connecting to API:

GS: Connecting to:wss://preview.gamesparks.net/ws/rest_of_url

 After that it just hangs up on that message, nothing more is printed in console so I intentionally de-focus Unity3D editor and click back to regain focus. After I do this, initialization proceed as normal. Eg it gets to state where it prints out:

GS: Available

I'm not sure what is causing this but intended to post it here in case anyone else having problems and trying to figure out what is going on. I could not trace what is causing this delay.

So in case anyone else have same problem just de-focus and re-focus Unity3D editor and it should continue.


(*) Even if I wait for couple of minutes without de-focussing editor window it won't proceed to message about "GS: Available"...


Cheers. 


3 people have this problem

@Andrew Hi, are you sure that you are entering the entire API secret? My problem as stated above was fixed by double clicking the API secret to select it all, then copying.
I am getting this problem too now, even though I am on 5.5.7.137!

 

Hi Ian,


We are aware of this issue and it will be addressed in an upcoming Portal update. 


Thanks,

Liam


1 person likes this
I got this working after reading through forums.

Liam, I recommend that you request that the dev team fix the webpage to allow the API Secret to be selected by dragging the the mouse curser out of the gui box. Currently, the only way to select the entire API Secret is by double clicking. Based on my current resolution on my laptop, there were about five characters that were off the screen and the last character was right on the edge which made the string look complete. I tried to select more by moving my mouse cursor outside of the GUI box just in case but it did not so I figured that was the whole string. Only once I read that someone else had realized that there was more to the string due to this issue did I think to double click it to select the entire string.

 

Hey guys, Ive used Gamesparks with Unity for a couple projects with no problems. I just start a new project and downloaded the latest SDK 5.4.0.104 I'm using Unity 5.4.3f1 and I'm on OS X El Capitan 10.11.6

I'm experiencing this same problem. When the SDK attempts to initialize it returns an authentication failure and loops likes 29 times and never connects... I tried unfocusing Unity and refocusing it but it doesn't fix the issue as some here said it did.

 

Hi Jeff, 


You're right it appears that the SDK page is linking to the old SDK(59). I'll get that updated.


Thanks,

Liam

+1 on the "it would be nice to have a full release history so we can now what actually changed between each release."  Odd that the SDK download page WOULDN'T point to the latest sdk....

Hi Fiete,


No problem, I'm glad to hear this worked for you.


Thanks,

Liam

Thank you Liam,
the new version works fine!

 

Thank you Liam,

This version is newer than the current link on your GameSparks Unity SDK download.  We'll give it a test tomorrow.

Hi Glenn/Fiete,


The issue you describe has been addressed in the latest SDK which you can grab here. Try that out and let me know how you get on.


Thanks,

Liam

 Same here, updated to the newest SDK and now Unity keeps crashing after every second compile. Really annoying!

We still see the Unity editor freeze up every other time you hit Play, on the latest version 5.4.  Is there any plan to fix this?  We were very anxious to try out GameSparks in our current project, but this is a bit of a non-starter.

The download link state : Gamesparks_Unity_5.3.3.171.unitypackage but it actually download a file called: Gamesparks_Unity_5.3.5.171.unitypackage

Hence the confusion.


I will try it out, it would be nice to have a full release history so we can now what actually changed between each release.

The most recent SDK is always available in the SDKs section of the docs website.
https://docs.gamesparks.net/sdk/unity3d-sdk

 

Login to post a comment