Sign In Register

How can we help you today?

Start a new topic

Cannot create Team


I got issue when creating teams.

I cannot create either by test harness or cloud code (Spark.sendRequestAs)

my game Id is gameId=120246

BTW, there are some entires in some of my leaderboards by NoSQL query, but no entires in Manage Tab.

So I cannot delete the unneeded entries.

Those leaderboards are created for team, and maybe it's related to the Create Team issue.

Please help



Hey Jo,

This is very strange behavior, and i couldnt reproduce it myself.
We had some server issues earlier today which may have been the cause; these issues have now been resolved, so perhaps you could check these errors are still occurring before i continue to investigate?



Hi Unfortunately it is still the same. I copied the snapshot to a new game before, and it's the same. Jo
(147 KB)


Any update for this?


Hey Jo,

Do i have your permission to log into your game and test this for myself?




Yes, Please test it in GameId = 295571.

Just made sure that you can duplicate the issue in that Env. 

In test hardness, Scenario, there are two saved Scenarios.

One for log in as test player, and the other to create Team to duplicate.




I just created a whole new game (id = 290457) . And I did the following steps:

1. add a team type

2. register a player in test harness

3. try to create a team in test harness, and then got the same error.

Maybe it's related to some specific machine?

I cannot use the team features at all if I cannot create a team.

Please help....

Thanks a lot


I just tested to create a team and for me it does not seems to work, in the Test harness i got this:

 "@class": ".CreateTeamResponse",
 "error": {
  "teamType": "INVALID"
 "scriptData": null

 "@class": ".CreateTeamRequest",
 "teamId": "testID",
 "teamName": "TestName",
 "teamType": "Clan"
Hi Did you create the team type named "Clan" in config UI? It seems that there is no Clan team type in your test env. , so it's invalid. Jo

thank i had missed this, now it work˜

sorry to hijack the thread but is there any way to save Team data ?

im thinking of different way 

-simplest way is saving on the owner but other player wont be able to update it

-most flexible would be using a collection accessible with the teamID (var clanDataCollection = Spark.runtimeCollection("clanDataCollection");)

-can it be done using leaderboards?

what would be best way for example if all team member would raise the level of the clan by adding experience and having common data like a base where they can add ressources to building and upgrade them ?

Hey Damien,

Do you mind posting your question on another thread, because it seems like a legit question other might have. I'd be afraid it'd get lost here.

Jo, so sorry about the delay.

I took a look at this with the config you had setup in your test-game, and i get exactly the same problem even with different configs until i tried a different team-name and it worked.
I tried tracing back the error, but i didnt get anything conclusive from this, so perhaps the team-name either exists, or maybe the creator of the team has been deleted while the team remains? I'm really not sure to be honest.
Will your game work with a different team-name?

I also did a 'GetTeamsRequest' to see what AreaTeam-types were already in use and i only got this newly-created one back, so thats not the error you were getting either. Im a little stumped, but maybe you could try it with some dummy-information and let me know if you still get these errors?



The game 295571 which you tried works now.

But I created a game 295722 which is almost zero-config (only add team type), still doesn't work.

My mainly testing game 120246 doesn't work either.

So I have to say the issue still happens.

According to your multi-stage publish suggestion, I may publish game snapshot to another game (different game ID), so it's not acceptable that some games ok, some games fail. 

Maybe it's related to the physics machine?


By setting the 'Max Members' and 'Max Membership' to be what you need, this should solve the problem.


It works now.


Login to post a comment