Sign In Register

How can we help you today?

Start a new topic
Answered

Getting "Unknown Service" error when starting scene

Set up a new Unity game - added the keys to the GameSparksSettings, dropped a GameObject in a login scene and added the GameSparksUnity script to it. When I run the scene I get:


GS: ERROR: UNKNOWN SERVICE


GS: Connecting to:wss://service.gamesparks.net/ws/291990lgXebL?deviceOS=WP8&deviceID=c1523c2e04eafdc138eca42531212f3d1fa9793c&SDK=



This happens in the test scene as well.


Best Answer

OK, looks like I figured it out. I had unchecked the Preview Build checkbox in the settings, which I'm guessing the 5.2.1.93 SDK requires.


Hey Jim,


It sounds like you may have an extra character or space in your api key or secret, can you double check this and if it's still an issue can you let me know which game it is in relation to and I'll investigate further.


Thanks,

Liam

There are no spaces in either one. I copy/pasted directly from the Configurator. The game is Word Chains.


Thanks for the help.

Noticed that the deviceOS param says WP8, but this is in a Unity game. Not sure that matters.

Hi Jim,


I've tested your key and secret for Word Chains here and I'm able to connect to Gamesparks fine, are you using any plugins ? Can you let us know what version of Unity and the GameSparks SDK you are on ? Don't worry about the OS saying WP8, it won't affect your connection, it's to do with the current build settings. If you get a chance set up a test project, import the GameSparks SDK, add your key and secret and let us know if that works.


Thanks,

Liam 

Answer

OK, looks like I figured it out. I had unchecked the Preview Build checkbox in the settings, which I'm guessing the 5.2.1.93 SDK requires.

Hi Jim,


Looking at your game again I can see you don't have any live snapshots published, so by having the preview box unchecked, you were essentially trying to connect to a live snapshot that didn't exist, this explains the error. When you have the preview box checked you will be connecting to a game in the preview environment. You would only need to uncheck this box when exporting a final build from Unity.


Thanks,

Liam


So a test project works fine using the key and secret, but I'm still not getting a connection in the game project. It doesn't throw the error, but the connection never happens. The only thing I'm using besides GameSparks is JsonDotNet from the Unity Asset Store and the Azure Mobile Services for Unity component, which requires JsonDotNet.

And all of the sudden everything seems to be working fine. :\

Hi Jim,


If it's ok just monitor it for now, try connecting/disconnecting from the test scene and sending some requests throughout the day. If you have any more problems let us know and we can look into this in more depth for you.


Thanks,

Liam

Login to post a comment