Sign In Register

How can we help you today?

Start a new topic
Answered

Issue with Netsockets on android and editor AFTER patching with good ol sockets

Hi


I wondered if someone could help please..


I discovered the net sockets issue for Unity free so bought good ol sockets and patched as this link suggested:


https://support.gamesparks.net/support/discussions/topics/1000044093


Now when I patched, good ol sockets told me the files it had patched so I changed:


----

lostpolygon.system.net


to


system.net

-----


I changed this in ONE file which was GameSparksEditorFormUpload.cs



Now I am in a position where the editor won't connect to gamesparks....and android doesn't either. But when I do a build for iOS it works fine.


Am i doing something wrong here?


I am using Unity 4.6.1f1 and latest version of good ol sockets which is 2.0.0.0



Best Answer

Hi


Managed to solve this by using the older GameSparks_Unity_3.2.3.unitypackage.


regards


Just to add this is the error I get after patching. I patched when I was in iOS as platform. And now when playing/testing int he unity editor I get this. Any help would be gratefully received as I need to deliver an Android build. The iOS one has worked fine



Just to add to this I have attached a screenshot of the error I now get when testing the game in the unity editor. I "patched" when i was in iOS platform if that is any relevance. As mentioned I have successfully done an iOS build and that works fine but the android version seems to fail at the same point the editor version does. Even though the patch seems to work as I don't get a prompt saying that android pro is required. Any help on this would be gratefully received as I need to deliver an Android buildĀ 

png
Answer

Hi


Managed to solve this by using the older GameSparks_Unity_3.2.3.unitypackage.


regards